[kaffe] JNI with Kaffe and ARM9

Dalibor Topic robilad at kaffe.org
Thu Aug 2 04:48:24 PDT 2007

Frederic Kwiatkowski wrote:
> Hi all
> I'm trying to use JNI with Kaffe but i've encountering some problems
> It's seems that my .so library to be found but when i'm using the main
> class, i've got the following error:
> # java fr.ptv.valence.katolecho.cannative.CanNative
> java.lang.NoSuchMethodError: main
>    at java.lang.VMThrowable.fillInStackTrace (VMThrowable.java:native)
>    at java.lang.VMThrowable.fillInStackTrace (VMThrowable.java:79)
>    at java.lang.Throwable.fillInStackTrace (Throwable.java:498)
>    at java.lang.Throwable.<init> (Throwable.java:159)
>    at java.lang.Error.<init> (Error.java:81)
>    at java.lang.LinkageError .<init> (LinkageError.java:72)
>    at java.lang.IncompatibleClassChangeError.<init> (
> IncompatibleClassChangeError.java:71)
>    at java.lang.NoSuchMethodError.<init> (NoSuchMethodError.java:72)

Hi Frederic,

Please try java -vmdebug NATIVELIB

that should give you an idea where kaffe is looking for the libraries,
and if it manages to find the library and functions you're trying to lookup.

And it would be interesting to see the class file. I've tried building
the source you sent on linux x86, and I didn't see the
NoSuchMethodError. Do you see the same error with Kaffe and the class
file on x86 - linux, too?

> Does anyone have ever used JNI with Kaffe on an ARM target? is there any
> particular argument to use during the building step?

Kiyo has just fixed up the JIT for ARM in CVS head, so I'd expect it to
work, as it's needed for the regression tests. Kiyo, what's the
regression test status on ARM in your setup?

dalibor topic

More information about the kaffe mailing list