[kaffe] Re: libz dependency

Kiyo Inaba inaba at src.ricoh.co.jp
Mon Jul 2 11:27:37 PDT 2007

Dalibor Topic wrote:
>Dalibor Topic wrote:
>> Kiyo Inaba wrote:
>>> Dalibor, could you please add some code to check the version of libz?
>> I could check if ZLIB_VERNUM >= 0x1230, and abort configure accordingly,
>> to make sure kaffe is built with zlib 1.2.3 or higher.
>fix checked in now. Thank you very much for the suggestion how to fix
>the problem, and for finding it.

Verified. When I have 1.2.3 version's zlib.h, compilation succeeds.
When I only have 1.1.4 version's zlib.h, it fails.

Then, I have two questions or comments.
1) "Can't find system..." or "Could not find..."
This newly added code uses error messages with current tense. But some
other error messages (Qt, GMP etc) usees past tense. Isn't it better
to integrate messages?

2) Runtime checking.
Current build tries to link with libz.so rather than libz.a. This
means, if we execute binaries compiled with v1.2.3 of zlib but
executed with v1.1.4 of zlib may introduce some mysterious bug as
I first encounter.
If someone can add runtime checking for the version, it should be
very helpful.

Anyway, these two are very minor and we can leave them as they are
till the release of 1.1.8.


More information about the kaffe mailing list