Appletviewer problems :-/

Daniel J. O'Connor doconnor at
Mon Apr 7 20:17:33 PDT 1997

I have compiled kaffe/biss-awt with Solaris and FreeBSD, but they both
don't seem to run appletviewer properly. ie when I load an applet(I
KNOW it works, netscape 2.01 runs it.) they open a window, and just
sit there doing nothing else :-/
Solaris doesn't say anything, but FreeBSD says -
[holly 12:39pm] ~/projects/Lotto> appletviewer lotto.html
[no file found!]
        at lotto.paint(365)
        at biss/awt/kernel/ unknown, pc 0x2e9980)
        at java/lang/ unknown, pc 0x2df582)

I have trie the biss calendar program(on FreeBSD) and it works
fine(although that doesn't use the appletviewer), so I assume most of
the awt is OK.

I also tried a REALLY simp[le applet, like draw a rectangle, but that
didn't do anything either... ARGH!!
The code is - 
import java.awt.*;
import java.applet.*;

public class foo extends Applet
        public foo()
        public void paint(Graphics g)
                g.drawRect(0, 0, 10, 10);

So its not really complex or anything :)
(This one doesn't say ANYTHING when I run appletviewer..)

DOes anyone have a quick fix for this? (please? ;)


More information about the kaffe mailing list