Shared libraries

Jon Skeet jon at
Mon Aug 4 04:42:18 PDT 1997

I'm using kaffe 0.91 on an Intel Linux box, and trying to use a package
which uses some native calls. (The package is cryptix, if that helps
anyone). I've built the native library and the java classes, and tried all
kinds of things to let kaffe "see" the library - but to no avail.

The error message is as follows:

Failed to locate native function:
        at cryptix/math/BigNum.<clinit>(34)

(rest of stack in my code)

Under the standard JDK for Linux, this works fine, so I presume it's just
a case of kaffe not finding the library. Some places I've tried putting
the shared library

The directory the test classes are in
The directory the kaffe binary is in

I've also tried copying it to, running ldconfig as root left
right and centre, setting (and exporting) LD_LIBRARY_PATH to be various
things... nothing seems to make any difference.

I'm more than slightly clueless about shared libraries, but I've run out
of daft ideas to try... anyone know how to make this work? I've got to use
Kaffe for my current project as it's built into Amaya...

Mailing replies to this address as well as to the list would be
appreciated... I'm only just putting myself on the list now, and I don't
know how long it'll take to start sending stuff through.

Thanks in advance,

Jon Skeet

More information about the kaffe mailing list