kaffe-0.9.1 on NetBSD-1.2.1

Shigeru IKEDA js3guj at gold.ocn.ne.jp
Sat Aug 30 10:28:52 PDT 1997


I tried to complie and install kaffe-0.9.1 on NetBSD-1.2.1. But
compilation of

* libkaffe_native.so
* libkaffe_zip.so
* libkaffe_vm.so

stopped with the following message (The numbers are different across the

ld: internal error: wrong number (378) of global symbols written into
output file, should be 395

After checking the source of ld and playing with it, I found that
NetBSD-1.2.1's ld counts global alias symbols as global symbols, but
it would not write global alias symbols, so the numbers do not
match. (I don't know whether it is the bug of NetBSD-1.2.1's ld or

I also found that all the global alias symbols are libc's.

And applied the following patch and re-autconf and tried to compile
again. (Maybe changing 'Makefile.in's is better.)

*** configure.in        1997/08/30 03:19:14     1.1
--- configure.in        1997/08/30 03:19:19
*** 702,708 ****
  dnl Checks for standard libraries
--- 702,707 ----

The result seems OK. I could compile, install, and pass the 'make

This patch seems OK on my Linux box (Debian based. kernel-2.0.29,
libc-5.4.20, gcc-, but I can not test on other plathomes.

Should I send the problem report of this with the report-kaffe-bug

Shigeru IKEDA <js3guj at gold.ocn.ne.jp>
PGP Key fingerprint = 11 7A 97 F4 82 E8 5A 5A  75 A8 F3 79 82 BB C2 C4

More information about the kaffe mailing list