Some notes on kaffe 0.8.1

Petter Reinholdtsen pere at
Mon Feb 24 17:32:36 PST 1997

I have tried to compile and run kaffe v0.8.1 on linuxelf and m68k
NetBSD without any luck, and thought I should send some notes which
might help further development.  I do not read this mailing-list

I fetched kaffe-0.8.1.tgz, and, unpacked and tried to compile on
NetBSD 1.2 running on HP9000/425.  It failed, because the linker tried
to make shared libraries using -Bdynamic.  When I changed this to
-shared, the whole system compiled.

When I tried to run the appletviewer, it crashed with illegal

I then compiled the same configuration on RedHat 4.0, without any
problems.  The problems arrived when I tried to run the appletviewer.
The system is apparently unable to load the X11 library.  After
loading some libraries, it gives me this message:

	kaffe: can't resolve symbol 'XSetErrorHandler'

I have no idea what is wrong, but I'll try a later version.  If
anybody would like me to test some spesific things, send a mail.
##>  Petter Reinholdtsen  <##  |  pere at

More information about the kaffe mailing list