installing kaffe

James Kevin Doyle jdoyle at
Tue Jul 1 11:13:39 PDT 1997

> i have been having some problems installing kaffe 0.90 on linux
> (debian, kernel version 2.0.30, i586). symptoms are:
> 1. numerous "Library load failed: File not found" errors. (nb compile
>    worked fine and all links to libraries are in place, installation
>    instructions were followed to the letter) is this a jit problem? an
> problem?
> 2. biss awt crashes out with a NullPointerException:
>    java.lang.NullPointerException
>            at java/awt/Font.initializeFont(105)
>            at java/awt/Font.<init>(119)
>            at biss/PackageProperties.getFont(158)
>            at biss/awt/Awt.initFonts(318)
>            at biss/awt/Awt.<clinit>(153)
>    presumably something to do with the fact that i don't have sun fonts
>    on my machine? tried making all the fonts in match
>    existing fonts on the system but to no avail.
> if anyone can give me a hand with this i'd be very grateful.

I had a problem like this when installing kaffe/biss on linux--in
particular I recognize the NullPointer in Awt.initFonts--and my
problem was that my C shared libraries were too old, that is, that the
major versions were right but the minor versions were old.
Essentially, when I upgraded from gcc 2.7.0 to gcc 2.7.2 including
necessary libraries like and so forth, kaffe/biss immediately
worked afterwards.  I should point out that kaffe had worked fine the
whole time, however; it was biss that had the problem that 
the newer libraries solved.  

So perhaps a first step would be to just check your shared libraries'

Jim Doyle
jdoyle at

More information about the kaffe mailing list