installing kaffe

dog dog at
Wed Jul 2 01:01:21 PDT 1997

James Kevin Doyle <jdoyle at> wrt:
> I had a problem like this when installing kaffe/biss on linux--in
> particular I recognize the NullPointer in Awt.initFonts--and my
> problem was that my C shared libraries were too old, that is, that the
> major versions were right but the minor versions were old.
> Essentially, when I upgraded from gcc 2.7.0 to gcc 2.7.2 including
> necessary libraries like and so forth, kaffe/biss immediately
> worked afterwards.  I should point out that kaffe had worked fine the
> whole time, however; it was biss that had the problem that 
> the newer libraries solved.  

ok. i have the following versions: = 5.4.23
  ldd = 1.8.10
  gcc =

should i have libc version 6?

also i tried installing kaffe with the epfl toolkit and that had
similar problems with gui. can i use sun's motif toolkit, and if so,
how would i go about it? i tried just including the jdk libraries in

  kaffe -Dawt.toolkit=sun.awt.motif.MToolkit ...

but there must be some other libraries it wants.

i still don't understand about the library load failure messages, though.


More information about the kaffe mailing list