installing kaffe

James Kevin Doyle jdoyle at
Wed Jul 2 09:02:33 PDT 1997

> >>>>> "James" == James Kevin Doyle <jdoyle at> writes:
>     >>  i have been having some problems installing kaffe 0.90 on
>     >> linux (debian, kernel version 2.0.30, i586). symptoms are:.....
>     James> I had a problem like this when installing kaffe/biss on
>     James> linux--....and my problem was that my C shared
>     James> libraries were too old, that is, that the major versions
>     James> were right but the minor versions were old.  Essentially,
>     James> when I upgraded from gcc 2.7.0 to gcc 2.7.2 including
>     James> necessary libraries like and so forth, kaffe/biss
>     James> immediately worked afterwards.
> Strange...
>     James> So perhaps a first step would be to just check your shared
>     James> libraries' versions.
> Close, but no cigar:
> Linux 2.0.29 #11 Sun Feb 16 01:35:16 EST 1997 i586
> /lib/  gcc version  ldd: version 1.9.2
> Fresh enough for you? Still kaffe/biss does not work. Kaffe without
> biss seems to work fine, like you said.  Biss is broken since 0.9.0
> release of kaffe, at least on my box.
> What did ou say the second step would be? (:-)

Well, I said it would be ... *perhaps* ... *a* first step.  Not *the*
first step.  And I hadn't gotten as far as a second step.  :-)

Sorry, just relating anecdotal information since the symptoms sounded
familiar.  (My diagnosis of the problem I had had was fairly
superstitious and just based on the fact that after changing the libs,
it worked.  I thought maybe since it was a NullPtr exception, an old
version of some C function was ignoring some pointer argument and
not giving it a value...)

Jim Doyle
jdoyle at

More information about the kaffe mailing list