kaffe 0.9.0 on sunos4.1.3 won't run

gjorstad gjorstad at atl.lmco.com
Wed Jun 4 11:24:19 PDT 1997

Thanos Siaperas wrote:
> Hello,
> I am having some problems with running kaffe on sunos:
>   I built kaffe 0.9.0 on a SunOS 4.1.3 platform, installed it with
> the default options ( at /usr/local) ,set the appropriate envs
> (LD_LIBRARY_PATH=/usr/local/lib
> KAFFEHOME=/usr/local/share/kaffe
> CLASSPATH=.:/usr/local/share/kaffe/classes.zip)
> then went to the test directory. When I ran
> gmake test, nothing worked. Messages are :
> -When ran on the originally compiled sunos 4.1.3 platform
> >Failed to locate native library in path:
> >       /usr/local/lib
> >Aborting.
> >Library load failed: ld.so: conflicting usage of dlopen'ed dependents
> - on a sunos 4.1.1 or 4.1.3_U1 platform
> >Cannot find essential class 'java/lang/Object' in class library ... >aborting.
> I would greatly appreciate any help you could provide.

I believe that the configuration between kaffe 0.8.4 (what I was using)
and kaffe 0.9.0 changed.  It seems to put duplicate -ldl statements in
the makefiles for each .so which causes the conflicting usage statement
you saw.  I have not forwarded this bug report to anyone at this point. 
However you can remove them manually and the error will go away.  (If
you need more detail on where these are I can send it to you.)

The "cannot find essential class..." error sounds like it really cannot
find classes.zip in the CLASSPATH.

However, right now, we are getting bus errors even on simple programs
using kaffe 0.9.0 on SunOS.  Please let me know if you get different


More information about the kaffe mailing list