kaffe + RMI & JDBC

Thanos Siaperas siaper at ced.tuc.gr
Thu May 29 16:37:19 PDT 1997

I tried to run a jdbc example with kaffe. With java on solaris, it
connects ok to the ( msql ) database.
With kaffe on sunOS 4.1.3, it issues the following:

java.sql.SQLException: No suitable driver
        at java/lang/Throwable.<init>(line unknown, pc 9da98)
        at java/lang/Exception.<init>(line unknown, pc ada7c)
        at java/sql/SQLException.<init>(72)
        at java/sql/DriverManager.getConnection(111)
        at java/sql/DriverManager.getConnection(134)
        at sl.main(9)
any ideas ?

Also, I tried to try RMI, by first trying to run
kaffe sun.rmi.registry.RegistryImpl. It complained with:
> RegistryImpl.main: an exception occurred: null
>        at java/lang/Throwable.<init>(line unknown, pc c4cc84)
>        at java/lang/Exception.<init>(line unknown, pc c52360)
>        at java/lang/RuntimeException.<init>(line unknown, pc c522e8)
>        at java/lang/NullPointerException.<init>(line unknown, pc c5227
>( ... some taken out ...)
>        at sun/rmi/transport/tcp/TCPEndpoint.exportObject(222)
>        at sun/rmi/transport/LiveRef.exportObject(114)
>        at sun/rmi/server/UnicastServerRef.exportObject(92)
>        at sun/rmi/registry/RegistryImpl.setup(88)
>        at sun/rmi/registry/RegistryImpl.<init>(74)
>        at sun/rmi/registry/RegistryImpl.main(216)
I would appreciate any ideas you could think of.
Thanks in advance.

Thanos Siaperas   siaper at ced.tuc.gr

PS. I have managed to get kaffe working, so please forgive my last
message about it not running.

More information about the kaffe mailing list