Michael Hirsch hirsch at
Fri Oct 3 20:49:11 PDT 1997

I have the same problem that Bryan Felix reported.

I tried to follow the README instructions exactly.  I got all four
kaffe-0.9.1.tgz and 
and unpacked them in the same directory.

./configure worked fine, as did make and make install.

But now:
[34] test> echo $CLASSPATH $KAFFEHOME
.:/usr/local/share/kaffe/ /usr/local/share/kaffe
[35] test> pwd
[36] test> kaffe HelloWorldApp
java.lang.ClassNotFoundException: HelloWorldApp
[37] test> 

I tried to do exactly as it says.  . is in the CLASSPATH.
I did not compile HelloWorldApp.fava into a .class file because 1) I
don't know how, exactly, and 2) the README doesn't say to.

However, if I try
[37] test> javac
my screen fills with this error message:
	at java/io/File.list(line unknown, pc 0x8520a6c)
	at sun/tools/java/ClassPathEntry.getFiles(line unknown, pc 0x8532197)
	at sun/tools/java/ClassPath.getFile(line unknown, pc 0x852ddb9)
	at sun/tools/java/ClassPath.getFile(line unknown, pc 0x8530bd6)
	at sun/tools/java/Package.getBinaryFile(line unknown, pc 0x853477a)
	at sun/tools/java/Package.classExists(line unknown, pc 0x852083b)
	at sun/tools/javac/BatchEnvironment.classExists(line unknown, pc 0x852c650)
	at sun/tools/java/Environment.classExists(line unknown, pc 0x8530369)
	at sun/tools/java/Environment.classExists(line unknown, pc 0x8530369)
	at sun/tools/java/Imports.importable(line unknown, pc 0x851ee55)
	at sun/tools/java/Imports.resolve(line unknown, pc 0x852d2db)
	at sun/tools/java/ImportEnvironment.resolve(line unknown, pc 0x8521eb3)
	at sun/tools/java/Environment.resolve(line unknown, pc 0x85205a2)
	at sun/tools/java/Environment.resolveName(line unknown, pc 0x851dea4)
	at sun/tools/java/Environment.resolveName(line unknown, pc 0x851dcca)
	at sun/tools/javac/SourceClass.resolveSuper(line unknown, pc 0x851ecd4)
	at sun/tools/javac/SourceClass.resolveSupers(line unknown, pc 0x852e895)
	at sun/tools/javac/SourceClass.resolveTypeStructure(line unknown, pc 0x852e1bd)
	at sun/tools/javac/SourceClass.basicCheck(line unknown, pc 0x851f971)
	at sun/tools/java/ClassDeclaration.getClassDefinition(line unknown, pc 0x851eb11)
	at sun/tools/javac/Main.compile(line unknown, pc 0x81b9992)
	at sun/tools/javac/Main.main(line unknown, pc 0x81a1d83)
error: An exception has occurred in the compiler; please file a bug report (
1 error

so clearly something is wrong with my setup.  I'm sure I'm missing
something obvious.

I tried 'make test', but each test failed with what appears to be
essentially the same error as the one quoted above.

Thanks in advance,

Michael D, Hirsch			Work: (404) 727-7940 
Emory University, Atlanta, GA 30322	FAX: (404) 727-5611
email:  hirsch at

Public key for encrypted mail available upon request (or finger
hirsch at

More information about the kaffe mailing list