Problems running kaffe on Win32/Linux

r robblau at MIT.EDU
Sat Nov 7 20:36:24 PST 1998


I am trying to get kaffe working on Win32 and Linux.
I have tried both the current snapshot (11/7) and 1.0b2,
but get the same behavior from both, under both OSes.

Everything compiles fine, yet the Klasses.jar file that is
built lacks many of the class files needed for kaffe,
notably java/lang/Object.  The Klasses.jar file that
is in the source distribution has these class files in
it (before the build, not after), but when I put this file
in the CLASSPATH with the ones that I have built, I receive
the following error:

java.lang.NoSuchMethodError: <init>
        at java/util/zip/ZipFile.entries(50)
        at pizza/v39/ClassReader.list(864)
        at pizza/v39/
        at pizza/v39/Enter.classEnter(387)
        at pizza/v39/Main.process(215)
        at pizza/v39/Main.compile(298)
        at pizza/v39/Main.main(372)
        at pizza/compiler/Main.main(20)

I have gone through the .c files and checked for header
files susceptible to Window's case insensitivity.  I have
tried the different options to configure that people on
this list have recommended (including specifying --prefix=/usr/local,
which somebody reported as fixing this problem).  I have had to copy
libmanagement.a to libmanagement.a.1.00.  Also under windows I have
had to move kaffe/scripts/bat to kaffe/scripts/.bat and move
the pizza and pizzadoc scripts into that directory.

With these changes, the make and make install run smoothly,
yet make test results in lang/java/Object not being found;
or with CLASSPATH updated, the above error.

Does anybody know how to fix this?

Much thanks,

-Robert Blau

More information about the kaffe mailing list