Problems running kaffe on Win32/Linux

Godmar Back gback at
Sun Nov 8 10:19:37 PST 1998

 Hi Robert,
Something is going wrong here.

First of all, the "NoSuchMethodError" results from the fact that your
Klasses.jar is somewhat out-of-date.  A recent fix requires you have an
up-to-date Klasses.jar.  In particular, 1.0b2's won't work.

That said:  the nightly automatic Klasses.jar is broken at the moment.
However, I did check in a version of Klasses.jar that I built. (Revision

Second, I don't know what you mean by "the Klasses.jar that is built" ---
building one is not yet part of the standard build process.  You can
rebuild it if you have a working Java compiler.

	- Godmar

> I am trying to get kaffe working on Win32 and Linux.
> I have tried both the current snapshot (11/7) and 1.0b2,
> but get the same behavior from both, under both OSes.
> Everything compiles fine, yet the Klasses.jar file that is
> built lacks many of the class files needed for kaffe,
> notably java/lang/Object.  The Klasses.jar file that
> is in the source distribution has these class files in
> it (before the build, not after), but when I put this file
> in the CLASSPATH with the ones that I have built, I receive
> the following error:
> java.lang.NoSuchMethodError: <init>
>         at java/util/zip/ZipFile.entries(50)
>         at pizza/v39/ClassReader.list(864)
>         at pizza/v39/
>         at pizza/v39/Enter.classEnter(387)
>         at pizza/v39/Main.process(215)
>         at pizza/v39/Main.compile(298)
>         at pizza/v39/Main.main(372)
>         at pizza/compiler/Main.main(20)
> java.lang.NullPointerException
> I have gone through the .c files and checked for header
> files susceptible to Window's case insensitivity.  I have
> tried the different options to configure that people on
> this list have recommended (including specifying --prefix=/usr/local,
> which somebody reported as fixing this problem).  I have had to copy
> libmanagement.a to libmanagement.a.1.00.  Also under windows I have
> had to move kaffe/scripts/bat to kaffe/scripts/.bat and move
> the pizza and pizzadoc scripts into that directory.
> With these changes, the make and make install run smoothly,
> yet make test results in lang/java/Object not being found;
> or with CLASSPATH updated, the above error.
> Does anybody know how to fix this?
> Much thanks,
> -Robert Blau

More information about the kaffe mailing list