Local stuff

gelderk at natlab.research.philips.com gelderk at natlab.research.philips.com
Fri Oct 9 05:48:49 PDT 1998


So, I managed to install all binaries HP-UX, 1.0.b2), but did not find
a proper way to tell Kaffe to look for libkaffevm in a better place,
so I hacked the binary ;-)

Now I can compile using pizza and run using kaffe.
I can even run sources with kaffe that were compiled with Sun's javac
(which should be possible by definition, of course).

But: my little application that counts down seconds until the year
2000 now has a flaw: it still counts down, but starts at 0, -1, -2, ...

The resized fonts in another application were _way_ too big.

Third application: ServerSocket gives a
  java.io.IOException: Resource temporarily unavailable
on accept() (at the same time java manages to listen, so it is not a
local, temporal problem).

All of these use some getLocal or getImpl method; is it all that bad?
I have tried the second one at home (Linux, 1.0.b1.rpm), which worked.

Finally, textFields do not seem to be working. Only cut-paste actions
and Capital characters as keys. The focus does work.
I remember the textFields working at home!

Anybody any idea? Any fixes? How well supported is the HP-UX 10.x


+--- Kero ------------------ kero at dds.nl ---+
| I ain't changed,                          |
| but I know I ain't the same               |
+--- M38C --- http://huizen.dds.nl/~kero ---+

More information about the kaffe mailing list