Chris Avis c.avis at
Wed Oct 14 18:53:35 PDT 1998

I have a RedHat5.1 Linux box that I thought I would try with JDMK3.0.
I copied the /opt/SUNWconn/jaw/classes directory to my linux box and
updated my CLASSPATH environment variable. When I ran the snmp agent
example I got the following message:

[chris at phobos chris]$ kaffe examples.snmp.agent.Agent
        at com/sun/jaw/reference/agent/cmf/Framework.initCmfInvoker(872)
        at com/sun/jaw/reference/agent/cmf/Framework.newObject(2394)
        at com/sun/jaw/reference/agent/cmf/Framework.newObject(466)
        at com/sun/jaw/reference/agent/cmf/Framework.newObject(574)
        at examples/snmp/agent/Agent.main(99)

Could someone tell me what this means, I presume it is some fatal
java language problem with the Kaffe VM. I then tried it with the
Sun JDK 1.1.6 and it seemed to work fine. Has anyone else got JDMK3.0
to work with Kaffe.

                Chris Avis (c.avis at
     _--_|\     RAMA Technologies Pty Ltd, 28 Walters Drive
    /      \    Osborne Park, Western Australia 6017, Australia
    \_.--._/    Tel: +61 8 9445 7999 Fax: +61 8 9445 7666

More information about the kaffe mailing list