Godmar Back gback at
Tue Oct 20 00:07:11 PDT 1998

> I have a RedHat5.1 Linux box that I thought I would try with JDMK3.0.
> I copied the /opt/SUNWconn/jaw/classes directory to my linux box and
> updated my CLASSPATH environment variable. When I ran the snmp agent
> example I got the following message:
> [chris at phobos chris]$ kaffe examples.snmp.agent.Agent
> java.lang.reflect.InvocationTargetException
>         at com/sun/jaw/reference/agent/cmf/Framework.initCmfInvoker(872)
>         at com/sun/jaw/reference/agent/cmf/Framework.newObject(2394)
>         at com/sun/jaw/reference/agent/cmf/Framework.newObject(466)
>         at com/sun/jaw/reference/agent/cmf/Framework.newObject(574)
>         at examples/snmp/agent/Agent.main(99)
> Could someone tell me what this means, I presume it is some fatal
> java language problem with the Kaffe VM. I then tried it with the
> Sun JDK 1.1.6 and it seemed to work fine. Has anyone else got JDMK3.0
> to work with Kaffe.

 I don't know whether anyone has gotten JDMK3.0 to run with kaffe and
in fact I don't even know what JDMK is, but I can tell you what the
message above means.  It means that an exception was thrown inside
a Method.invoke().  This exception is packaged inside a InvocationTargetExc.
If you had the source, (I assume you don't since it's a com.sun.  package, 
though I might be wrong), you could extract the exception and print its 
backtrace; then you'd know exactly where the actual failure occurred.

	- Godmar

More information about the kaffe mailing list