1 Question and 2 minor bug-fixes

gelderk at natlab.research.philips.com gelderk at natlab.research.philips.com
Thu Oct 8 09:27:14 PDT 1998


I tried to compile 1.0.b1 on a "HP-UX B.10.20 A 9000/820" once, which failed.
I tried version b2 now (not the snapshot), but a lot of the same errors occur.

Installing into some other directory than /usr/local is not that easy, is it?

So I have:
1) A question
2) Some bugfixes for Makefile(.in)


+--- Kero ------------------ kero at dds.nl ---+
| I ain't changed,                          |
| but I know I ain't the same               |
+--- M38C --- http://huizen.dds.nl/~kero ---+



After installing into /home/gelderk I get:
  /usr/lib/dld.sl: Can't open shared library: ../kaffevm/libkaffevm.sl
  /usr/lib/dld.sl: No such file or directory
where /usr/lib/dld.sl does exist! 

Problem is in `Kaffe`, which gets called. Which library mechanism does
not want to look into my library-path, but tries a relative path?!?

where libkaffevm.sl is in /home/gelderk/lib



Bugs found when running `make` (HP make) I am not a Makefile expert, but I
needed to change the things below to be able to run `make` to completion.

Furthermore `make install prefix=/home/kero` is not processed as I would like
it: make does not propagate the prefix down into subdirectories it calls. I
have no fix for this one, only an idea: you could put things like INSTROOT and
prefix into install-sh instead of all those makefiles.

gmake on the other hand has no problem with any of these bugs.
gmake does not have trouble with the fixes below, either.

	Last line of OBJECTS= should not end in a backslash

	Change all $< into $? (Hm, at least the first four occurences)


More information about the kaffe mailing list