configure problems

jim hopper hopperj at
Wed Aug 11 12:36:19 PDT 1999

>On Aug 11, 1999, jim hopper <hopperj at> wrote:
> > checking for ld used by GCC... sed: -e expression #1, char 7: Unterminated
> > `s' command
>What do you get with `gcc -print-prog-name=ld'?  What if you run

i get the expected result.

>configure with bash (CONFIG_SHELL=/bin/bash /bin/bash configure
>--args)?  You might also try to get libtool.m4, ltconfig and
>from the latest snapshot (or libtoolize -f with the latest libtool)
>and see if this changes anything...  Or you can just set the
>environment variable LD to point to

i changed configure to

#!/usr/bin/bash from #!/usr/bin/sh

this fixed the problem with finding the linker.  it doesnt really 
answer whats wrong with sh, but i can look at that seperatly later, i 
can live with this fix ;-)
> > as to the size, i am doing a native compiler on machten using gcc
> > 2.8.1.
>Are there filename size limitations?  For example, if the limit was 8
>characters, it would try to read from `conftest' instead of


> > configure:2429: gcc -o conftest.xcoff -g -fsigned-char   conftest.c  1>&5
>                                 ^^^^^^
>Ah, wait!  This looks like an autoconf bug that mis-detects .xcoff as
>the executable extension, just because the linker creates a file with
>that extension *in addition* to the executable.  I'm not sure the bug
>has already been fixed in newer releases of autoconf, but you can
>always override it by setting `ac_cv_exeext=""' in your environment.

yes this was the problem.  i had picked this up and tried building 
from command line with this and it didnt object to -o being this but 
when i setenv variable ac_cv_exeext=""  it worked fine.  so i looked 
at what is wrong with the configure script.  the following change 
needs to be made:

echo $ac_n "checking for executable suffix""... $ac_c" 1>&6
echo "configure:1181: checking for executable suffix" >&5
if eval "test \"`echo '$''{'ac_cv_exeext'+set}'`\" = set"; then
   echo $ac_n "(cached) $ac_c" 1>&6
   if test "$CYGWIN" = yes || test "$MINGW32" = yes; then
   rm -f conftest*
   echo 'int main () { return 0; }' > conftest.$ac_ext
   if { (eval echo configure:1191: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5;
}; then
     for file in conftest.*; do
       case $file in
       *.c | *.o | *.obj | *.xcoff ) ;;                  <==== added | *.xcoff
       *) ac_cv_exeext=`echo $file | sed -e s/conftest//` ;;
     { echo "configure: error: installation or configuration problem: compiler
cannot create executables." 1>&2; exit 1; }
   rm -f conftest*
  test x"${ac_cv_exeext}" = x && ac_cv_exeext=no



At a recent computer software engineering course in the US, the participants
were given an awkward question to answer.  "If you had just boarded an
airliner and discovered that your team of programmers had been responsible
for the flight control software, how many of you would disembark
                     unknown author

More information about the kaffe mailing list