Compiling Kaffe under NetBSD 1.3.3/m68k/amiga

Kiyo Inaba inaba at
Mon Feb 8 19:43:49 PST 1999

>I'm trying to install Kaffe 1.0.b3 on my system.
>But i got everytime the same error during the link phase.
>It complain about the lack of function named m68k_fixup_trampolines.
>What the hell is it?
>A kernel options?
>I looked into source and i found in sourcedir/config/m68k/ a piece of code
>named trampolines.c that seem to define the function above.,but only if the
>code is compiled using static lib,so i tried.. , and this time the source is
>compiled without any problems,but the binary fails when executed.

I've never touched NetBSD 1.3.3/m68k/amiga but I use NetBSD 1.3.1/m68k/sun3
and Kaffe 1.0.b3 works with some problem. First of all, as I reported
by another mail, the jit+jthreads combination makes a binary which
pizza does not like :-< But, even with this configuration, simple
HelloWorld test works.

On the other hand, if you use the jit+internal combination you
may have less problems. Or the most stable one is intrp+jthreads,
with which you may have only one or two problems in the regression
test case.


More information about the kaffe mailing list