Current kaffe broken ?

Maksim Lin maksim at
Mon Jan 11 17:06:46 PST 1999

I've just checked out the current kaffe srcs out of the CVS, but I got a
error while trying to build it of:

creating .libs/KaffeS.c
extracting global C symbols from `main.o'
(cd .libs && gcc -c -fno-builtin "KaffeS.c")
gcc -g -O2 -Wall -Wstrict-prototypes -o .libs/Kaffe .libs/KaffeS.o
-Wl,--export-dynamic -lm -lm -lm -lz -lm -lm -lm -ljpeg -lpng -lz -lgif
-L/usr/X11R6/lib -lSM -lICE -lX11 -lm main.o -Wl,--rpath
-Wl,/usr/local/lib ../kaffevm/.libs/ -lm -lm -lm -lm
../kaffevm/.libs/ undefined reference to `dlerror'
../kaffevm/.libs/ undefined reference to `dlclose'
../kaffevm/.libs/ undefined reference to `dlopen'
../kaffevm/.libs/ undefined reference to `dlsym'
make[2]: *** [Kaffe] Error 1
make[2]: Leaving directory `/home/maks/src/kaffe/kaffe/kaffe'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/maks/src/kaffe/kaffe'
make: *** [all-recursive] Error 1   

I'm not sure whether this is me having done something wrong or with the
new automake procedure (my last build of srcs I checked out a week ago
worked perfectly), since when I ran configure --program-prefix=k, the
messages I got looked like the configure process was happening twice and
then it looks like it gets repeated again when you make (or is this
whats supposed to happen with using automake ?).

BTW I have old versions of automake & autoconf dtected, but the error
messages from configure said that this would only be a problem if I
wanted to change the srcs, which I haven't (or have got this wrong too

I'd appreciate any pointers as I'm a bit confused by the whole
autoconf/automake system.


Maksim Lin
IBM walks the walk
Sun talks the talk
Microsoft can't even think the thought 
- An anonymous coward on

More information about the kaffe mailing list