[Kaffe] problems running kaffe on IRIX 6.2.

Moses DeJong dejong at cs.umn.edu
Fri Mar 5 17:20:42 PST 1999


I tried to compile and install Kaffe on an IRIX box using
egcs-2.91.60 19981201 (egcs-1.1.1 release) but I had
some problems. First off, the configure script did not
seem to include my X lib directory in the shared lib path.
I had to do this before I could run anything.

% setenv LD_LIBRARY_PATH /soft/X11R6.3/lib

Then when I ran kaffe I got this error.

% /tmp_mnt/project/neon/users/mo/kaffe/install/bin/kaffe
19264:/tmp_mnt/project/neon/users/mo/kaffe/install/libexec/Kaffe: rld: Error: unresolvable symbol in /usr/lib32/libiflJFIF.so: __pure_virtual_called

That symbol is in libC.so.

% nm -Bo libC.so | grep pure_virtual
libC.so: 09a15e78 T __pure_virtual_called

% cd kaffe/kaffe

I added -lC to lib tool link line and that fixed it.

Why exactly does kaffe need C++ stuff? I thought was written in C.
Is there something I am missing?

I am also a little unsure how to fix this problem. Is this something
that should go in the IRIX parts of the configure script?

Mo Dejong
dejong at cs.umn.edu

More information about the kaffe mailing list