[Kaffe] problems running kaffe on IRIX 6.2.

Lee Iverson leei at ai.sri.com
Fri Mar 5 17:41:29 PST 1999

In message <Pine.SGI.4.05.9903051918450.19282-100000 at neon.cs.umn.edu> you write
> Hello.
> I tried to compile and install Kaffe on an IRIX box using
> egcs-2.91.60 19981201 (egcs-1.1.1 release) but I had
> some problems. First off, the configure script did not
> seem to include my X lib directory in the shared lib path.
> I had to do this before I could run anything.
> % setenv LD_LIBRARY_PATH /soft/X11R6.3/lib

That's bizarre.  You're not using SGI's X installation then?

> Then when I ran kaffe I got this error.
> % /tmp_mnt/project/neon/users/mo/kaffe/install/bin/kaffe
> 19264:/tmp_mnt/project/neon/users/mo/kaffe/install/libexec/Kaffe: rld: Error:
>  unresolvable symbol in /usr/lib32/libiflJFIF.so: __pure_virtual_called
> That symbol is in libC.so.
> % nm -Bo libC.so | grep pure_virtual
> libC.so: 09a15e78 T __pure_virtual_called
> % cd kaffe/kaffe
> I added -lC to lib tool link line and that fixed it.
> Why exactly does kaffe need C++ stuff? I thought was written in C.
> Is there something I am missing?

This doesn't really have anything top do with kaffe.  The problem is
that the libiflJFIF.so library (-ljpeg) is not `closed' and requires
-lC or -lCsup to be linked with it in order to link.  Really ugly and
stupid and OS and Image Format Library version dependent.  In any
case, the following configure.in patch works for me (YMMV):

diff -p -u -r1.82 configure.in
--- configure.in        1999/03/01 19:56:59     1.82
+++ configure.in        1999/03/06 02:44:02
@@ -449,6 +449,9 @@ else
+  dnl Checks for libraries (-lCsup is necessary on some SGI systems)
+  AC_CHECK_LIBRARY(Csup, __T_9__nothrow,JPEG_LIBS)

Lee Iverson     		SRI International
leei at ai.sri.com			333 Ravenswood Ave., Menlo Park CA 94025
http://www.ai.sri.com/~leei/	(650) 859-3307

More information about the kaffe mailing list