Help Compiling under Solaris

Kris Bubendorfer Kris.Bubendorfer at MCS.VUW.AC.NZ
Mon May 10 20:55:09 PDT 1999

Hi All,

I've tried compiling on a Sparc Solaris with little success.  Configure 
completes, but seems to generate a bad MakeFile, in that an inline pipe 
command is missing prior to the sed when making the libraries.

I've tried both make and gmake to no avail, and can't make head nor tail of 
the config script myself.  The output is included below...

Any Ideas?

mkdir .libs
ln -s ObjectStreamClassImpl.lo ObjectStreamClassImpl.o
ln -s sha-1.lo sha-1.o
ln -s ClassLoader.lo ClassLoader.o
ln -s Class.lo Class.o
ln -s Compiler.lo Compiler.o
ln -s Double.lo Double.o
ln -s Float.lo Float.o
ln -s Math.lo Math.o
ln -s Object.lo Object.o
ln -s Runtime.lo Runtime.o
ln -s SecurityManager.lo SecurityManager.o
ln -s String.lo String.o
ln -s System.lo System.o
ln -s Thread.lo Thread.o
ln -s Throwable.lo Throwable.o
ln -s UNIXProcess.lo UNIXProcess.o
ln -s CharToByteDefault.lo CharToByteDefault.o
ln -s ByteToCharDefault.lo ByteToCharDefault.o
ln -s ZipFile.lo ZipFile.o
ln -s MemoryAdvice.lo MemoryAdvice.o
ln -s Array.lo Array.o
ln -s Constructor.lo Constructor.o
ln -s Field.lo Field.o
ln -s Method.lo Method.o
ln -s DateFormat.lo DateFormat.o
ln -s TestNative.lo TestNative.o
rm -fr .libs/libnative.lax
mkdir .libs/libnative.lax
generating symbol list for `'
/usr/bin/nm -B  ObjectStreamClassImpl.lo sha-1.lo ClassLoader.lo Class.lo 
Compiler.lo Double.lo Float.lo Math.lo Object.lo Runtime.lo SecurityManager.lo 
String.lo System.lo Thread.lo Throwable.lo UNIXProcess.lo CharToByteDefault.lo 
ByteToCharDefault.lo ZipFile.lo MemoryAdvice.lo Array.lo Constructor.lo 
Field.lo Method.lo DateFormat.lo TestNative.lo |  | sed 's/.* //' | sort | 
uniq > .libs/libnative.exp
../../../libtool: syntax error at line 1: `|' unexpected
gmake[3]: *** [] Error 2
gmake[3]: Leaving directory `/am/circa/home/kris/PhD/OpenVM/kaffe/libraries/cli
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/am/circa/home/kris/PhD/OpenVM/kaffe/libraries/cli
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/am/circa/home/kris/PhD/OpenVM/kaffe/libraries'
gmake: *** [all-recursive] Error 1


Cheers Kris...

More information about the kaffe mailing list