libtool-enhanced testing on HP-PA

Kero van Gelder gelderk at
Fri May 28 09:15:10 PDT 1999

> > Since HP-UX has neither working system call tracing (at least it
> > doesn't work too well on our installation at work) or "ldd"
> AFAIR, HPsUX's ldd is called chatr (sp?).

chatr exists, the man-page says
 "change program's internal attributes".
ldd does not exist.

> > Has the HP version been tested since the integration of libtool?
> Only two weeks ago someone spotted and fixed a bug in libltdl that
> would prevent libltdl from minimally working on HP/UX.  It's reported
> to be working now (in libtool 1.3), but I don't think anyone has tried
> Kaffe snapshots after my last libtool import.  I'd appreciate any
> feedback.

A miracle just happened: compilation out-of-the-box of Kaffe managed
to launch the biggest Java package I have written.

That is, with shared libraries! (Somebody else may try the static ones :-)
Kaffe works under HP/UX 10.20!

OK, now the problems: I can't get a KeyEvent through my Canvas. I've
had this same problem a couple of versions ago on Linux, where I tried
to solve them with Focus, but without reaching compatibility with
Sun's jdk. The problem has been solved for Linux, though, 'coz I
remember popping up a Frame as a consequence of such a KeyEvent.

Pressing TAB a few times kind-of worked then, but does cause any
reaction, now.

In combination with IceWm, Kaffe does not continue when I switch to
another virtual screen. That is, it consumes CPU cycles, but does
nothing useful. Both for Linux and HP-UX. WindowDeactivated problem?
Focus problem? IceWm problem?

Kero van Gelder.

+--- Kero ------------------ kero at ---+
| I ain't changed,                          |
| but I know I ain't the same               |
+--- M38C --- ---+

More information about the kaffe mailing list