large Class.forName() patch
archie at whistle.com
Mon Jan 31 13:12:09 PST 2000
Jason Baker writes:
> > #define INTEGER_PRIMITIVE_CLASS "I"
> > and use INTEGER_PRIMITIVE_CLASS instead of "int".. would this work?
> No, its even worse, since a class in the anonymous package is alot
> more likely to be called "I" than "int". We can use "I" only where a
> class would be L<path>;.
Good point.. what about
#define INTEGER_PRIMITIVE_CLASS ";I"
#define BOOLEAN_PRIMITIVE_CLASS ";Z"
Archie Cobbs * Whistle Communications, Inc. * http://www.whistle.com
More information about the kaffe