Problems with kaffe-1.0.6 on alpha

Simon Greaves Simon.Greaves at
Tue Sep 5 15:06:57 PDT 2000

Thanks for the response,

> If you re-configure with "--enable-debug", and then run with '-vmdebug 
> GCDIAG', Kaffe will run a lot of sanity checks on the heap for each
> allocation.  Also, 'kaffe -fullversion' will tell us which threading
> system and which jit/intrp engine is being used.

I extracted a fresh copy of the source tree and ran 'configure
--enable-debug' which seems ok. Then I ran 'make' which fails whilst
compiling kaffe/kaffevm/debug.c:

debug.c:43: conflicting types for `kaffevmDebugMask'
debug.h:156: previous declaration of `kaffevmDebugMask'
debug.c:47: conflicting types for `dbgSetMask'
debug.h:205: previous declaration of `dbgSetMask'
make[3]: *** [debug.lo] Error 1

where those definitions are (in order of above error):
jlong kaffevmDebugMask = DEFAULT_DEBUG_MASK;
extern long long kaffevmDebugMask;

dbgSetMask(jlong mask)
void dbgSetMask(long long mask);

So, noting that 'long long' and 'long' are both 8 bytes on Alpha's, and
that jtypes.h looks like it typedef's 'long' to 'jlong', I tried editing
the two lines fron debug.h above, changing the definitions from 'long
long' to 'long'. The make then works but again 'make check' fails.

TestScript: 10600 Abort - core dumped
TestScript: 1596 Abort - core dumped
TestScript: 31398 Abort - core dumped

Trying the suggestion above with my simple 'HelloWorld' class:

% /usr/local/bin/kaffe -vmdebug GCDIAG Samp
mem/gc-mem.c:315: failed assertion `blk->free != 0'
Abort (core dumped)

% /usr/local/bin/kaffe -fullversion
Kaffe Virtual Machine
Copyright (c) 1996-2000
Transvirtual Technologies, Inc.  All rights reserved
Engine: Interpreter   Version: 1.0.6   Java Version: 1.1
Configuration/Compilation options:
  Compile date  : Wed Sep 6 09:29:52 FJT 2000
  Compile host  :
  Install prefix: /usr/local
  Thread system : unix-jthreads
  CC            : gcc
  CFLAGS        : -g -O2 -Wall -Wstrict-prototypes -mieee
  LDFLAGS       : -export-dynamic
  ChangeLog head: Mon Jul 24 14:00:00 PDT 2000  Tim Wilkinson
<tim at>

> From the GDB backtrace, its loading 'java.lang.Short' which is the
> 11th basic class to be loaded... perhaps there's something going funny
> in the JIT?  I've no idea what the status of Kaffe on Alpha is
> (frankly, I'm surprised it got as far as it did :)...

Ah. I had rather blithely assumed Alpha's were supported... Can anyone
clarify this? If it's a portability issue, I'd be prepared to put some
effort into getting it working, though time (and ability :-) may be a
limiting factor.

> Good.  You don't have a stale installation of Kaffe lying around that
> might be getting in the way?

No. Compaq/Digital JDK's are installed, but I don't have any reference to
them in my environment.
> You can check where the classes are actually being loaded from by
> running a debugging build of Kaffe like:
> 	'kaffe -vmdebug INITCLASSPATH asdf'
> That'll print full paths to various .jar files Kaffe is using.

Looks ok to me..

% kaffe -vmdebug INITCLASSPATH asdf
initClasspath(): '.:/usr/local/share/kaffe/Klasses.jar:
insertClasspath(): '.' append
insertClasspath(): '/usr/local/share/kaffe/Klasses.jar' append
insertClasspath(): '/usr/local/share/kaffe/comm.jar' append
insertClasspath(): '/usr/local/share/kaffe/pjava.jar' append
insertClasspath(): '/usr/local/share/kaffe/servlet.jar' append
insertClasspath(): '/usr/local/share/kaffe/tools.jar' append
insertClasspath(): '/usr/local/share/kaffe/microsoft.jar' append
insertClasspath(): '/usr/local/share/kaffe/kjc.jar' append
insertClasspath(): '/usr/local/share/kaffe/rmi.jar' append
mem/gc-mem.c:315: failed assertion `blk->free != 0'
Abort (core dumped)

More thoughts/comments?

Simon Greaves				voice: (+679) 212114
Computer Centre				fax:   (+679) 304089
The University of the South Pacific	email: Simon.Greaves at
Suva, Fiji

More information about the kaffe mailing list