some regression test of kaffe 1.0.6 failed on linux

Patrick Tullmann tullmann at
Thu Sep 21 11:38:49 PDT 2000

> After I successfully compiled kaffe 1.0.6 on linux, I tried "make
> check". To my surprise, some of the regression test failed, including
> That means kaffe 1.0.6 doesn't support thread preemptive
> scheduling, which is an important problem. While kaffe 1.0.5 support it.
> I tried on both linux 2.0.36 and linux 2.2.1. How could this happened?

That is odd.  Which threading system is Kaffe using?  (kaffe -fullversion 
will tell you.)

Both of the relevant ones (unix-pthreads and unix-jthreads) support
preemption.  Perhaps something odd happened, like not finding
SIGTVALRM or something?  What version of Linux (kernel/distro) are you

If you compile and run, what happens?


----- ----- ---- ---  ---  --   -    -      -         -               -
Pat Tullmann                                       tullmann at
       Don't hate yourself in the morning -- sleep until noon!

More information about the kaffe mailing list