Problem during Installation

Edouard G. Parmelan egp at
Sat Apr 21 11:16:33 PDT 2001

Valentin Valchev wrote:

> This is a verry strange problem I encountered when tried to compile bash for qnx.
> A firend of mine used: 
>     ./configure --host=
> And this worked!??!?

Kaffe need to know cpu and os for his thread subsystem and/or his
exception support. Script configure loads
config/$Khost_cpu/$Khost_os/config.frag file.

Well, you must update config.sub to a new version that handle i386-qnx,
see attached patch.  And use i386-qnx as host type.

Note that last change on i386/QNX port was done on 1999 :-(

I quick read config/i386/qnx/* files and I think you can remove special
definition of sysdepCallMethod in config/i386/qnx/md.h as new version of
this macro let's GCC handle return value in registers or in other place.

Hope this help.
Edouard G. Parmelan
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.sub.diff.gz
Type: application/octet-stream
Size: 1864 bytes
Desc: not available
Url : 

More information about the kaffe mailing list