[kaffe] tomcat3.2.3 doesn't work properly on Kaffe-1.0.6-6

Tatsuya Tsurukawa turukawa at isl.melco.co.jp
Wed Jun 19 17:29:21 PDT 2002

I've tried to get tomcat 3.2.4 run on kaffe-1.0.7-rc1 and three
patches dalibor attached previous mail.

I could see sample servlets work well as you mentioned, but 
Apache-SOAP 2.2 still didn't work.

I also found the following code included in Apache-SOAP 
RPCRouterServlet.java replies different value depending on JVM. 

public void init() throws ServletException {
    ClassLoader servletClassLoader = getClass().getClassLoader();

Although the value "sun.misc.Launcher$AppClassLoader at 22961b " is
returned as servletClassLoader in case of using JDK1.3.1, null
returns in case of Kaffe.

Calling stacks are as follows.
at java.lang.NullPointerException.<init>(NullPointerException.java:17)
at java.util.Hashtable.put(Hashtable.java:104)
at org.apache.tomcat.core.Context.setAttribute(Context.java:411)
at org.apache.tomcat.facade.ServletContextFacade.setAttribute(ServletContextFacade.java:116)
at org.apache.soap.server.http.ServerHTTPUtils.setServletClassLoaderIntoContext(ServerHTTPUtils.java:144)
at org.apache.soap.server.http.RPCRouterServlet.init(RPCRouterServlet.java:173)
at javax.servlet.GenericServlet.init(GenericServlet.java:258)

Does anybody know the reason why null is returned, and are there any
work arounds ?

Best regards,
Tatsuya Tsurukawa

Dalibor Topic wrote:
>--- Tatsuya Tsurukawa <turukawa at isl.melco.co.jp>
>> I'm now testing Apache SOAP 2.2 and TOMCAT 3.2.3 on
>> Red Hat Linux 7.2.
>> to make simple Web Services. 
>> They work well on Sun's JDK1.3.1. Then I tried to
>> use Kaffe-1.0.6-6 as
>> JVM instead of Sun's JDK, and I found it doesn't
>> work. I saw follwing
>> errors.
>I just had a success to get tomcat 3.2.4 running on
>current kaffe from CVS with the attached patches from
>Tim Stack.
>* how I got it to run:
>- got latest kaffe from CVS
>- applied attached patches
>- compiled and installed
>- got the tar.gz package from jakarta.
>- extracted it
>- added all jars in the lib/ directory to the
>- ran it with
>kaffe -Dtomcat.home=<path-to>/jakarta-tomcat-3.2.4/ 
>- tested the servlet examples. all worked for me on
>lynx and mozilla.
>- the jsp examples failed since the JSP engine wanted
>to explicately use sun's javac as the java compiler.
>there might be a way to get around it by setting an
>option to use jikes instead, but I didn't try it. Just
>adding kaffe's rt.jar and classes.zip from JDK 1.1.8
>to the classpath worked for me. A better solution
>would be to write a KjcCompiler class.
>I hope this helps 
>dalibor topic
>Do You Yahoo!?
>Yahoo! - Official partner of 2002 FIFA World Cup

Tatsuya   turukawa at isl.melco.co.jp

More information about the kaffe mailing list