[kaffe] (no subject)

Sanjeev Manral sanjeevm at sanyo.co.in
Wed Oct 30 21:43:57 PST 2002


I've removed static inline but it is giving the same error.

I've complied kaffe by using #if 0" out the asm floating point references in
config/powerpc/sysdepCallMethod.h.  stuff like:  register double d0

But if I run kaffe on my ppc405 board. It is running fine for help eg.
./java -version and ./java -help
is wokring properly
but when I trying to run some class file
./java HelloWord
I've put HelloWord in the same directory
It's giving segmentation fault and rebooting the system.
Is it because of #if 0 in sysdepCallMethod or some oher problem(like path
settings etc).

How can I do the following-
Maybe it's better to switch on fpu emulation in kernel, rather than =
using soft floating points of glibc.

Thanks in advance,

-----Original Message-----
From: Timothy Stack [mailto:stack at cs.utah.edu]
Sent: Wednesday, October 30, 2002 10:45 PM
To: sanjeevm at sanyo.co.in
Cc: kaffe at kaffe.org
Subject: Re: [kaffe] (no subject)

> hi tim,


> I'm writing it for linux and arch is IBM PowerPC405 . I'm compiling the
> present one but getting the error-
> /***********ERROR LOG *************/
> In file included from
> /opt/hardhat/devkit/ppc/405/bin/../target/usr/include/stdio.h:33,
>                  from debug.h:31,
>                  from support.c:12:
> include/stddef.h:170: warning: empty declaration
> In file included from
> /opt/hardhat/devkit/ppc/405/bin/../target/usr/include/stdlib.h:391,
>                  from ../../config/config-std.h:15,
>                  from support.c:14:
> /opt/hardhat/devkit/ppc/405/bin/../target/usr/include/sys/types.h:106:
> warning: empty declaration
> support.c: In function `sysdepCallMethod':
> support.c:1051: Internal compiler error:
> support.c:1051: internal error--insn does not satisfy its constraints:
> (insn 998 995 507 (set (reg/v:DF 40 f8)
>         (mem:DF (plus:SI (reg:SI 31 r31)
>                 (const_int 8 [0x8])) 0)) 441 {*movdf_softfloat32} (nil)
>     (nil))
> make[3]: *** [support.lo] Error 1
> make[2]: *** [all-recursive] Error 1
> make[1]: *** [all-recursive] Error 1
> make: *** [all-recursive] Error 1
> /***********END ERROR LOG *************/

I agree with dalibor, you should try upgrading.  Another thing you can try 
though is just compiling the sysdepCallMethod separately (its getting 
inlined up there, so remove "static inline" and just compile the file), 
that will give us a better idea of where the problem is.

> Thanks,
> Regards,
> Sanjeev

tim stack

More information about the kaffe mailing list