[kaffe] (no subject)

Timothy Stack stack at cs.utah.edu
Thu Oct 31 07:32:23 PST 2002

> hi,
> I've removed static inline but it is giving the same error.

Well yeah, that was the idea, we're interested in getting a real line
number and not the bogus one gcc reported in your previous error message.  
You could also try "gcc -S", feeding the output to the assembler, and
getting a real line number there, but i guess you figured out the

> I've complied kaffe by using #if 0" out the asm floating point references in
> config/powerpc/sysdepCallMethod.h.  stuff like:  register double d0
> asm("fr1");
> http://www.kaffe.org/pipermail/kaffe/2002-July/008630.html

Weird, i don't remember writing that... :)

Anyways, the advice is the same, you need to figure out how floating point 
parameters are passed when soft floating point is enabled.  So, google 
around or try to infer it from the output of "gcc -S" on some simple 
floating point program.

> But if I run kaffe on my ppc405 board. It is running fine for help eg.
> ./java -version and ./java -help
> is wokring properly
> but when I trying to run some class file
> ./java HelloWord
> I've put HelloWord in the same directory
> It's giving segmentation fault and rebooting the system.
> Is it because of #if 0 in sysdepCallMethod or some oher problem(like path
> settings etc).

Well, the help message doesn't do anything particularly sophisticated, so 
its no surprise that it works.  And, i imagine some floating point is done 
to get the VM going, so thats probably why it died.

> How can I do the following-
> http://www.kaffe.org/pipermail/kaffe/2002-July/008631.html
> Maybe it's better to switch on fpu emulation in kernel, rather than =
> using soft floating points of glibc.

i dunno, sorry

> Thanks in advance,
> Regards,
> Sanjeev

tim stack

More information about the kaffe mailing list