Problems with CygWin (was: Re: [kaffe] undefined references in kaffeh)

Dalibor Topic robilad at
Mon Jul 14 01:18:01 PDT 2003

Hi Andrea,

Andrea Scian wrote:
> I'm sorry for the last e-mail but it seems that I have made some mistakes while updating from the CVS... in fact I download it again and now it works!
> it still required the patch for jthread.c and give me an error with a cygwin include file (cygwin/types.h), but now I fix it and I get a working Kaffe on my CygWin!
> Thanks for you help

I'm glad that it works now. I've checked in a patch for replace/inet_*.c 
  that fixes the include file problems. I get a working build when I 
configure kaffe to build as a static binary on cygwin, while dynamic 
builds don't work yet because of missing symbols. Most regression tests 
fail unfortunately, since compiling with kjc on cygwin causes a weird 
segmentation violation in jar.c. Someone on cygwin should look into it. 
I'm not familiar with x86 assembler, so I can't say if something fishy 
is going on. But it looks like stack corruption, since I'm getting 
segmentation violations for access to local variables in jar.c.

It would be great, if you could try to get the dynamic builds to work as 
well. Please take a look at . 
This chapter contains the necessary information on how to update the 
sourcecode and to allow building of DLLs on windows.

Of course, all patches fixing kaffe's gcc warnings on Cygwin are welcome 
as well.

dalibor topic

More information about the kaffe mailing list