[kaffe] (no subject)

samuel samuel at hectrix.com
Fri Jun 6 02:36:02 PDT 2003

	I've tried to make kaffe work with qt-embedded-3.1.2, but I  
still can't get it work. Can anyone help?  
	I've built the QT independently, and built kaffe with the  
parameter "--with-awt=qt --with-qtdir=/root/qt-embedded-3.1.2". After  
make install the above, I export QTDIR, KAFFESRC, KAFFINSTALL and  
LD_LIBRARY_PATH. And I get some errors when I compile the  
	First, I got an error show that the line 256 of toolkit.h("char  
xor;") and it's fixed after I change it to ("char Xor"). I detailly  
describe it is because I don't know will this affect the others.  
	After fixed the first error, it claim that my moc version not  
compatiable. It's caused from the "evt.moc":  
******************************ERROR MESSAGE**************************  
In file included from evt.cc:984:  
evt.moc:15:2: #error "This file was generated using the moc from  
3.0.3. It"  
evt.moc:16:2: #error "cannot be used with the include files from this  
version of Qt."  
evt.moc:17:2: #error "(The moc has changed too much.)"  
/root/tools/qt-embedded-free-3.1.2/include/qstringlist.h: At top  
evt.cc:243: warning: `char *eventStr (int)' defined but not used  
make: *** [evt.o] Error 1  
***************************END of ERROR MESSAGE**********************  
After I comment the error message from the "evt.moc", another error  
******************************ERROR MESSAGE**************************  
gra.cc:99: parse error before `^'  
gra.cc: In function `void Java_java_awt_Toolkit_graDrawPolygon (JNIEnv  
*, void *, Graphics *, void *, void *, int)':  
gra.cc:335: warning: unused variable `int n'  
***************************END of ERROR MESSAGE**********************  
And many other error appears after the above change. What should I do?  
I am only a beginner in kaffe, hope that someone can help me. Thanks  
---------- Original Message ----------------------------------  
From: Dalibor Topic <robilad at yahoo.com>  
Date:  Tue, 3 Jun 2003 16:39:09 -0700 (PDT)  
Hi Samuel,  
--- Samuel <samuel at hectrix.com> wrote:  
> Hi All,  
>     I've tried again and again, but I still cannot fix it. I am  
using the  
> kaffe 1.0.7 and qt-embedded 3.2.0. I got error message when I make  
> kaffe-awt-qt. Could anyone tell me which version they are use and  
> success? I have already read the readme.qt also. Anyone have any  
ideas are  
> welcome. Thank you.  
check out this thread for more information on what I did to get kaffe  
to run. http://www.kaffe.org/pipermail/kaffe/2003-March/029009.html  
I was using kaffe from CVS and qt-embedded-free 3.1.2.  
dalibor topic  
p.s. it might be helpful to post the actual error messages you get,  
just in  
case someone has already seen them ;)  
Do you Yahoo!?  
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).  
kaffe mailing list  
kaffe at kaffe.org  

More information about the kaffe mailing list