[kaffe] (sigh) Kaffe 1.1 can't do FEC decoding

Dalibor Topic robilad at yahoo.com
Fri Jun 13 05:28:01 PDT 2003

Hi Greg,

--- Greg Wooledge <greg at wooledge.org> wrote:
> So, after a week of failures every time I tried to download an FEC
> splitfile from Freenet, using Kaffe 1.1 (or the CVS version from
> right before the release), I decided that perhaps it's Kaffe that's
> causing the problem, rather than Freenet.

it usually is ;)

> Then I went back to the early-May Kaffe (and gmp-3.1.1) and the
> most recent Freenet build I have; I clicked it, took the defaults
> on the web form, and the operation finished in 37 seconds.  I had
> the file.

Hm, any chance of pinpointing the exact checkin on kaffe that started failing
FEC ? kaffe -fullversion of the last version that works, kaffe -fullversion of
the first version that fails, and an ugly binary search over checkouts, I guess
;) There have been quite a few changes to the core libraries in the last 4

> freenet.node.ds.FSDataStoreElement$KeyInputStreamImpl.<init>(FSDataSt
> oreElement.java:237)
>         at

what does this code do?

> (Forgive me for not sewing the lines back together.)  I don't know
> if this error is directly related to the FEC splitfile errors; but
> on my system at least, Kaffe 1.1 fails to even *begin* an FEC decode,
> 100% consistently.  (And it leaks memory like an upside-down bucket.)

yeah, the memory leaking is really weird. Have you tried running with
--verbosemem to see where all that memory goes?

dalibor topic

Do you Yahoo!?
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).

More information about the kaffe mailing list