[kaffe] (sigh) Kaffe 1.1 can't do FEC decoding

Greg Wooledge greg at wooledge.org
Fri Jun 13 14:31:01 PDT 2003

Dalibor Topic (robilad at yahoo.com) wrote:

> yeah, the memory leaking is really weird. Have you tried running with
> --verbosemem to see where all that memory goes?

As you may recall, we tried to track it down a few months back by
applying a "counter" patch to kaffe, but it didn't work out because
Freenet never calls exit().  Then Mark J. Roberts (mjr) did something
which may or may not have been useful for you; it was a bit over
my head.

--verbosemem doesn't seem to produce any output with the early-May
CVS version.  I left the node running for about 10 minutes and
made a fair number of local requests (in addition to whatever came
in over the network).  I was seeing a lot of strange failures in
loading some of the images on some of the pages though; I didn't
attempt to track it down.

I repeated the experiment with 1.1.0 and within a few minutes it
had died:

$ java --verbosemem -mx 200M freenet.node.Main
Internal error: caught an unexpected exception.
Please check your CLASSPATH and your installation.
Abort (core dumped) 

#0  0x401f9fcf in _thread_sys_kill ()
#1  0x401f98bb in abort ()
#2  0x400394e5 in unhandledException (eobj=0x3350d38) at exception.c:513
#3  0x40039387 in dispatchException (eobj=0x3350d38, baseframe=0x27f040)
    at exception.c:470
#4  0x40038ffb in throwException (eobj=0x3350d38) at exception.c:235
#5  0x40038f77 in throwError (einfo=0x26f4b9c) at exception.c:217
#6  0x40056d0b in soft_fixup_trampoline (_data=0x3235cd) at soft.c:583
#7  0x4008280e in i386_do_fixup_trampoline () at machine.c:1187
#8  0x4005b4ae in callMethodV (meth=0x306560, func=0x3235c8, obj=0x26f4b9c, 
    args=0x40056c76 "[\201Ãêó\003", ret=0x26f4ef8)
    at ../../config/i386/common.h:38
#9  0x4005a5d3 in do_execute_java_method_v (obj=0x1588e00, 
    method_name=0x4005c60d "finish", signature=0x4005becb "()V", mb=0x0, 
    isStaticCall=0, argptr=0x26f4f6c "") at support.c:161
#10 0x4005a658 in do_execute_java_method (obj=0x1588e00, 
    method_name=0x4005c60d "finish", signature=0x4005becb "()V", mb=0x0, 
    isStaticCall=0) at support.c:187
#11 0x4005c6a0 in exitThread () at thread.c:441
#12 0x4005c5a7 in firstStartThread (arg=0x1588e00) at thread.c:402
#13 0x400857e8 in start_this_sucker_on_a_new_frame () at jthread.c:1266
#14 0x40085968 in jthread_create (pri=1073856528, func=0x97, 
    daemon=1074116611, jlThread=0x10ff960, threadStackSize=0) at jthread.c:1336
#15 0x40096060 in _GLOBAL_OFFSET_TABLE_ ()
#16 0x8b000575 in ?? ()

Greg Wooledge                  |   "Truth belongs to everybody."
greg at wooledge.org              |    - The Red Hot Chili Peppers
http://wooledge.org/~greg/     |
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://kaffe.org/pipermail/kaffe/attachments/20030613/39fb9b24/attachment-0002.pgp 

More information about the kaffe mailing list