[kaffe] Classpath problems...

Dalibor Topic robilad at yahoo.com
Fri Jun 20 00:56:01 PDT 2003

Hallo Clemens,

--- Clemens Eisserer <ceisserer at utanet.at> wrote:

> I tried to run some Mica-Examples with Kaffe, the same command worked with
> sun-java, why do I get class-not-found-error?
> Whats wrong?
> ce at linux:~/mica-20030415/apps> kaffe -classpath
> "/usr/lib/kaffe/lib/rt.jar:.:mica.jar" MiPerformanceTestSuite
> java.lang.NoClassDefFoundError: com/swfm/mica/MiJCanvas
>         at com.swfm.mica.MiNativeWindow.<init>(MiNativeWindow.java:84)
>         at com.swfm.mica.MiEditorWindow.<init>(MiEditorWindow.java:83)
>         at
> com.swfm.mica.MiFileEditorWindow.<init>(MiFileEditorWindow.java:173)
>         at
> MiPerformanceTestSuiteWindow.<init>(MiPerformanceTestSuite.java:301)
>         at MiPerformanceTestSuite.main(MiPerformanceTestSuite.java:88)

I assume it uses swing. Read FAQ/FAQ.awt on hot to get swing working.

dalibor topic

Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!

More information about the kaffe mailing list