[kaffe] AWT runntime bug

Justin Dearing jdearing at cuthbeat.com
Tue Mar 11 04:40:01 PST 2003

Hello all,
I wrote the attached class that runs fine on Sun's JDK. However, when I
run it on Kaffe I get the error at the bottom of the email. It freezes
at the exception and the Frame is never displayed. I have to crtl-c out
of it. If I simply comment out one off the drawButton() calls it works
fine in Kaffe. I tried the latest cvs code, tried binaries compiled
against both kaffes and sun's sdk and I even tried using jikes with
kaffe's bootclasspath. I assume its some kind of garbage collection
issue. Any insight would be helpful

bash-2.05b$ kaffe exceptionFrame
        at java.awt.GridBagLayout.getGrid(GridBagLayout.java:366)
        at java.awt.Container.layout(Container.java:387)
        at java.awt.Frame.layout(Frame.java:153)
        at java.awt.Container.doLayout(Container.java:186)
        at java.awt.Container.validateTree(Container.java:731)
        at java.awt.Container.validate(Container.java:724)
        at java.awt.Window.show(Window.java:360)
        at exceptionFrame.main(exceptionFrame.java:100)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: exceptionFrame.java
Type: text/x-java
Size: 2603 bytes
Desc: not available
Url : http://kaffe.org/pipermail/kaffe/attachments/20030311/aca821a4/attachment-0003.java 

More information about the kaffe mailing list