[kaffe] Bug Report with partial fix

Dalibor Topic robilad at kaffe.org
Fri Oct 24 02:52:02 PDT 2003

Hi Ross,

Thanks for the patch. I tried applying it, but it didn't work for me:
bash-2.05a$ patch -p 1 --dry-run -i /var/tmp/message.eml
patching file libraries/javalib/java/awt/ImageLoader.java
patch: **** malformed patch at line 106: // we are done with it, prevent 
memory leaks

Could you resend to me as an attachment?

Before I apply it, since this your first patch to kaffe, according to
our ChangeLog, I need your confirmation that you're not 'tainted', i.e.
have looked at Sun's sources, decompiled their class libraries, or
signed an NDA preventing you from contributing to a free java effort.

It may sound like too much legalese, but we need to protect you and 
ourselves from somebody pulling an SCO on us. ;)

See http://www.gnu.org/software/classpath/docs/hacking.html#SEC2 for 
more information on Classpath's definition of clean-room conditions. 
They are the same for kaffe, except that we don't ask for copyright 
assignment to the FSF.

Ross Martin wrote:
> Hi Guys,
> I've been trying to get kaffe's appletviewer to work with RuneScape, 
> which you can try as follows:
> appletviewer 
> "http://www.runescape.com/client.cgi&world=4&plugin=0&rand=66351490"

Runescape looks quite cool!

> Kaffe without patches fails to even load the applet.  I've attached a 
> patch that fixes kaffe/applet/AppletTag.java
> and java/awt/ImageLoader.java to at least get it to the load stage and 
> display some of the animations.


> However, there is still a bug that I haven't yet figured out.  For some 
> reason, the mouse clicks aren't
> being translated to the correct position for the Panel containing the 
> Applet.  As a result, you have to click
> with the mouse 10-20 pixels too high to get the buttons to register.  
> I'd like some help with this last
> problem, if someone could be so kind.

It's been a long time I've fought with the AWT code, but I can try once 
we have your patches checked in.

> I've tried running kaffe's AppletViewer.class using Sun's java, and this 
> loaded the Applet fine and
> produced the correct mouse translation.  So the problem isn't in the 
> AppletViewer.  It's probably
> somewhere in kaffe's behind-the-scenes mouse event dispatch code.  I 
> only have a vague idea how
> this is supposed to work, so I'm hoping someone else could either find 
> the problem or help me
> understand what is supposed to happen so I can better debug where it 
> goes wrong.

sounds like we'll have some fun ;)

dalibor topic

More information about the kaffe mailing list