[kaffe] kaffe 1.1.0 on Darwin

Michael Franz developer.franz at verizon.net
Tue Apr 20 05:39:02 PDT 2004


Kaffe has compiled on Darwin/OS X for a while, but it has always failed 
the tests.  The VM is corrupt and does not work for compiling the 
tests.  Dalibor had made a change that allows Kaffe to build and test 
with an externally provided rt.jar, that does help in debugging the 
problems with the VM during the build process.  This is how I configure 
Kaffe for a build:
# --with-rt-jar=<absolute path to rt.jar>
./configure --with-rt-jar=/Users/mfranz/dev/kaffe_rt.jar 
--with-jikes=no --enable-debug --enable-pure-java-math --disable-shared

The rt.jar should be the built from the same source as you are 
compiling (within reason).  This can be compiled on a different 
platform, since it is byte code.

I tried 1.0.7 on OS X 10.1.x and it failed on a link (-L /usr/local/lib 
-lnative) or something like that.  /usr/local/lib does not exist and I 
don't know what library -lnative is suppose to be.

On Tuesday, April 20, 2004, at 06:12 AM, Riccardo wrote:

> Hello,
> In the pursue of if and when Kaffe worked on darwin, I tried 1.1.0 
> today.
> It builds fine and fails about everything except the first test

With the above configuration I don't think any pass (1.1.4).

> PASS: HelloWorldApp.class.save
> error compiling:
> ./../../kaffe/kaffevm/file.h:69: failed assertion `((buf == NULL) && (
> len == 0))|| ((buf != NULL) && (len != 0))'
> TestScript: line -43: 29082 Abort trap              
> /Users/multix/kaffe-
> 1.1.0/kaffe/kaffe/kaffe-bin at.dms.kjc.Main -classpath ".:.::.:/Users/
> multix/kaffe-1.1.0/libraries/javalib/kjc.jar" -d . ./HelloWorldApp.java
> FAIL: HelloWorldApp.java
> 133 of 137 tests failed
> I wonder if this is always the same problem that changes "appearance"
> throughout the versions...
I think the issue is the same, but changes to the build process and 
other code move it around.  So, yes, I agree.


More information about the kaffe mailing list