[kaffe] A question about "JNI_OnLoad"

Guilhem Lavaux guilhem at kaffe.org
Mon Aug 2 02:21:58 PDT 2004

embstudy at eyou.com wrote:

>   Yes,I am a little bit sure that the question is not related to
>"JNI_OnLoad". But I don't agree that it is the architecture that cause the
>problem. In my opinion, the Qtopia1.7(based on QTE-2.3.7) is the most possible
>We have successfully got the plain text "Helloworld" run in two condition,but
>definitely failed after we startup the qtopia GUI. :(
>Host  : Redhat-9, Dell machine
>target: Xscale develope board (Pxa255,400MHz)
>Comm  : minicom(run on Redhat-9),Jtag,sometimes use telnet
>CVS.v : 7.18.2004 (we tried update the kaffe, but failed at some compilation
>1st condition:
>We use the minicom(or telnet) to logon to the target, through ttyS0, and then
>cmd "kaffe Helloworld", we could successfully got the right result.
>BTW,we couldn't run the GUI programs at this circumstance.
>When we tried as "kaffe -v -ss 128000 -cp $PWD -vmdebug AWT Calc",
>we just got this:
>2nd condition:
>We just startup the target machine, and set runlevel 3, without start the
>qtopia GUI. Then we use the USB keyboard to input cmds directly on the target
>This time we can run the "Helloworld" successfully too. 
>But we couldn't run the GUI test program because there is no qws server
>So we were told to add "-qws" there, but it seems impossible to pass this para
>rightly now.
>But after we start the qtopia, no matter we use the embeddedconsole or
>someother ways, even the javac fails at the same error.
>We couldn't run the "Helloworld" successfully at this time!
>If it's the architecture reason, then how to explain the two conditions I just
>referred to?
>So I think the keypoint is the difference caused by the qtopia. Did qtopia
>bothers kaffe to run successfully? 
>BTW,where is the exact point for me to find out the difference?
>Any hints?
Hi !

Thank you for the detailed testings. As HelloWorldApp is working, we can 
eliminate sysdepCallMethod. However, I don't see how qtopia may 
interfere in initProperties. Is it possible for you to have gdb precise 
stacktrace of the point where it gets a NPE in the native code ? I don't 
see why it should be a setProperty call, but maybe something more system 



More information about the kaffe mailing list