[kaffe] Kaffe 1.0.7 on OS X 10.2.8

Michael Franz developer.franz at verizon.net
Sun Jun 13 21:49:03 PDT 2004

Hi All,

I have been able to solve my problems with kaffe 1.0.7 on OS X 10.2.8.  
It compiles with only 12 failures (114 tests) (10.1.5 has 2 failures).  
The steps are as follows:
1. define CPP=/usr/bin/cpp - solves issue with configure not finding cpp
2. run configure --with-staticlib

This will work with unix-jthreads and unix-pthreads.

I will check if these steps also work on 10.1.5 and then move onto 
kaffe 1.1.5/head

On Sunday, June 13, 2004, at 05:51 PM, Michael Franz wrote:

> Hi,
> I have made some headway with getting the last version that worked on 
> OS X 10.1.5 to build on OS X 10.2.8.  The configure script is not 
> identifying cpp correctly and is thus trying to use /lib/cpp which is 
> incorrect.  This causes config.h to be missing a bunch of headers 
> which causes the kaffe to not build.
> What is the correct way to fix this?  To fix this fo my compiles I 
> 'export CPP=/usr/bin/cpp' and then run configure.
> The next problem is that the libtool is not working correctly when 
> building the libnative-1.0.7.so.  I have tried to upgrade to the 
> latest tool set without success.
> I will keep digging.
> Michael
> _______________________________________________
> kaffe mailing list
> kaffe at kaffe.org
> http://kaffe.org/cgi-bin/mailman/listinfo/kaffe

More information about the kaffe mailing list