[kaffe] Re: kaffe & AWT

Fabien Renaud renaud at nentec.de
Tue Jun 15 05:50:02 PDT 2004

Dalibor Topic wrote:

> Fabien Renaud wrote:
>> I recompiled kaffe-1.1.4 and I have the same error.
>> I think there is no problem with libqt (well not too much) because I 
>> can run java programms written with QT.
>> It´s maybe due to different gcc compilator (2.95 for qte and 3.3.1 
>> for qtjava, kaffe)
> Hi Fabien,
> quoting from FAQ.awt:
>   * Linker complains about missing symbols
>     That could be an instance of moc trouble above, but more often
>     it's a problem between C++ ABIs of the compiler used to build qt
>     you want to link against, and the compiler you used to build
>     kaffe's Qt-based AWT with.
>     The GNU C++ compiler g++ had a short period where the ABI changed
>     with almost every release, so if you are using a Qt library
>     compiled with one of those 'interim' versions, your best bet is to
>     rebuild Qt frim scratch with your current compiler.
> Either use the compiler you used for qte (2.95) to compiler kaffe. Or 
> rebuild qte with 3.3.1. It will not work otherwise. That's not a bug a 
> kaffe, it's the way C++ support in g++ evolved, so that it is 
> impossible to link c++ object code compiled by two different releases 
> of g++ (unless you are very lucky).
> cheers,
> dalibor topic
That´s strange I hadn´t problems. I had some link problems which I 
solved with -fno-rtti flag.

I´ll  try to recompile qt ( I try and din´t succed)


More information about the kaffe mailing list