[kaffe] Kaffe as Installed JRE in Eclipse

Michael Franz m.franz at verizon.net
Sun Jun 20 16:24:02 PDT 2004

I have tried to build eclipse 3.0M9 with kaffe 1.1.4.  It looked like 
it worked (but it really didn't).  There are some things missing, like 
AWT/Swing that are somehow used within the build.  I had to change 
about 10 xml files to get it to recognize os=linux ws=gtk arch=ppc.  
Took about 7 hours on my G3 400.  It actually takes longer if you use 
jikes - I think the call to a none java applications has more overhead 
than the slow intrp.

Doing the same build on an x86 takes about 13 minutes (no kaffe VM).

On Sunday, June 20, 2004, at 06:46 PM, Arnaud Vandyck wrote:

> Michael Franz <developer.franz at verizon.net> writes:
>> Hi,
>> I am trying to use Kaffe as an installed JRE inside of Eclipse.  When 
>> I
>> try to run a simple program I get this error.  Couldn't find or load
>> essential class `java/lang/Object' java.lang.NoClassDefFoundError
>> java/lang/Object
>> Has anyone tried this before?  Any success?  I am using Eclipse 3.0 
>> RC2.
> I'm still trying to build it! (linux/gtk/ppc)
> But it seems it does not find rt.jar/Klasses.jar
> -- 
> Arnaud Vandyck
> I'm personally quite happy with one stable release every two years, and
> am of the opinion that trying to release more will mean we'll have to
> rename the distro from "stable" to "wobbly".
> 		-- Scott James Remnant on debian-devel
> _______________________________________________
> kaffe mailing list
> kaffe at kaffe.org
> http://kaffe.org/cgi-bin/mailman/listinfo/kaffe

More information about the kaffe mailing list