[kaffe] JVMPI status?

Jon Nall nall at themountaingoats.net
Thu Mar 11 09:34:02 PST 2004

Dalibor Topic wrote:

> yep, I get the same problem with jprofiler-1.1.1. It seems to be some 
> weird memory allocation issue. I haven;t tried tracking it down.

i figured out why it's happening, though i'm not familiar enough with 
the project (yet) to suggest the proper fix. the issue is that in 
function argz_create_sep() at libltdl/ltdl.c:627 argz is LT_DLMALLOC'ed. 
and in foreach_dirinpath() at libltdl/ltdl.c:2705 is LT_DLFREE'ed. 
however, configure found argz_create_sep() on my system defined in 
/usr/include/argz.h and set the following in libltdl/config.h: #define 

this, i assume, causes the external argz_create_sep call which just uses 
plain old malloc(). send that to LT_DLFREE and chaos ensues.

i hand-modified libltdl/config.h to say #undef HAVE_ARGZ_CREATE_SEP, 
recompiled and can now run ejp without error.

i've tried both of the following successfully:
1. never use the external argz_create_sep() call
2. add an ifdef in foreach_dirinpath() that calls normal free() for argz.

with either of these fixes, i still get a core dump:
kaffe-bin: jvmpi_kaffe.c:55: jvmpiPostEvent: Assertion `ev->event_type < 

if someone can tell me which of 1 or 2 above to pursue, i'll create a 
patch and get that assert debugged.


More information about the kaffe mailing list