[kaffe] java.util.date problem (on SH4 & X86)

Kiyo Inaba inaba at src.ricoh.co.jp
Sun Nov 14 02:03:03 PST 2004

Hi Takahiro,

OK, I've been back to Japan...

You said,
>We tried to build kaffe-1.1.4 for SH4/linux,and It seems to 
>have succeeded in build.


I double checked kaffe-1.1.4 but it can not be configured simply.

First I try (based on FAQ.cross-compiling)
      CC={mycc for sh3} NM={mynm for sh3} AR={myar for sh3} \
      ../kaffe-1.1.4/configure \
      --host=superh-linux --build=i686-linux \
      --with-staticbin --with-staticlib --with-staticvm \
      --enable-pure-java-math \
      --with-threads=unix-jthreads \
      --disable-sound --without-x
and I got while configuring 'libltdl' saying
  checking host system type... Invalid configuration `superh-linux': machine `superh' not recognized
  configure: error: /bin/sh ../../kaffe-1.1.4/libltdl/./config.sub superh-linux failed

This error makes sense, because 1.1.4 uses libltdl and it has its own config.sub...

If I replace '--host=superh-linux' to be '--host=superh-unknown-linux-gnu' or modify
config.sub, (and additionally fix problem in config/superh/linux/md.h), I got
kaffe-bin compiled. But, by using this kaffe-bin, regression tests failed as
    error compiling:
    java.lang.ClassNotFoundException: at.dms.kjc.Main
       at kaffe.lang.AppClassLoader.findClass (AppClassLoader.java:296)
       at java.lang.ClassLoader.loadClass (ClassLoader.java:142)
    FAIL: HelloWorldApp.java

I am in doubt that this error should be CPU specific or build-environment specific.

Could you please post your configure line with (if exists) your mod to the source code?
Or, noone else can trace your effort, I believe.

P.S. I know that if we back port dalibor's fix, these problem can be solved. But,
     this is another story.

More information about the kaffe mailing list