[kaffe] Kaffe on XScale

Jari Korva jpkorva at iki.fi
Tue Oct 19 01:04:24 PDT 2004

On Thu, 14 Oct 2004, Helmer [ISO-8859-15] Krämer wrote:
> On Tue, 12 Oct 2004 11:00:10 +0300 (EEST)
> Jari Korva <jpkorva at iki.fi> wrote:
> > there was an additional f0 lurking (see below). Because my Assembly is
> > pretty bad, I just removed it blindly - but it made Kaffe to compile!
> >
> > The resulting Kaffe does not quite work though (throws an NPE in
> > System.initProperties, see bottom of this message).
> I've just commited a fix so that System.initProperties doesn't
> crash when setlocale returns NULL.

I tried inserting some printfs to initProperties and it seems that it
doesn't even reach that function. Similar results in debugger as well.

Then I tried adding a debug call to static block of System.java. Even that
doesn't work:

/wrk/ipaq/u/jko/test/bin/java -cp test.jar hello
Internal error: caught an unexpected exception.
Please check your CLASSPATH and your installation.
        at java.lang.System.debug(System.java:native)
        at java.lang.System.<clinit>(System.java:43)
        at java.lang.ClassLoader.<init>(ClassLoader.java:115)
        at java.lang.ClassLoader.<init>(ClassLoader.java:111)
        at java.net.URLClassLoader.<init>(URLClassLoader.java:544)
        at kaffe.lang.AppClassLoader.<init>(AppClassLoader.java:237)
        at kaffe.lang.AppClassLoader.<clinit>(AppClassLoader.java:35)

Is JNI broken on armv5b?

- Jari

More information about the kaffe mailing list