[kaffe] varous netbsd ppc errors

Riccardo zuse at libero.it
Sun Oct 24 11:36:54 PDT 2004

after pthread compilation fails, I have tried jthreads. Using KJC I get 
the following:

[ parsed javax/swing/undo/CannotRedoException.java in 286 ms ]
[ parsed javax/swing/undo/CannotUndoException.java in 236 ms ]
[ parsed javax/swing/undo/CompoundEdit.java in 2,452 ms ]
[ parsed javax/swing/undo/StateEdit.java in 1,740 ms ]
[ parsed javax/swing/undo/StateEditable.java in 453 ms ]
Internal error: caught an unexpected exception.
Please check your CLASSPATH and your installation.
java/lang/NoClassDefFoundError: java/lang/InterruptedException
        at java.lang.Runtime.exitJavaCleanup(Runtime.java:97)
        at java.lang.System.exitJavaCleanup(System.java:144)
/rebuildLib: line 60: 13516 Abort trap              (core dumped) 
gmake[3]: *** [lib/stamp] Error 134
gmake[3]: Leaving directory `/home/multix/kaffe-cvs/netbsd-intrp-jthread/

so I compiled using Jikes.

The I run make check (with kjc of course) and it fails nevertheless:

gmake[5]: Entering directory `/home/multix/kaffe-cvs/netbsd-intrp-
assertion "gcFunctions[fidx].description != NULL && size != 0" failed: 
file "../../../../kaffe/kaffe/kaffevm/kaffe-gc/gc-incremental.c", line 
1036, function "gcMalloc"
gmake[5]: *** [ClassToInterface.class] Abort trap (core dumped)
gmake[5]: Leaving directory `/home/multix/kaffe-cvs/netbsd-intrp-jthread/

it is strange though that KJC was previously able to build a great part 
of the class library file and then fail... immediately in the 


More information about the kaffe mailing list