[kaffe] Configure Under SuSE 9.1
noa at resare.com
Tue Oct 26 01:14:32 PDT 2004
tis 2004-10-26 klockan 01:24 -0400 skrev Michael Franz:
> To configure kaffe under SuSE 9.1, I have to use the
> --disable-native-awt, but do not understand why. The error message I
> get (when I don't) is this:
> checking for pkg-config... /usr/bin/pkg-config
> checking for gtk+-2.0 >= 2.4 gthread-2.0 >= 2.2 libart-2.0...
> Requested 'gtk+-2.0 >= 2.4' but version of GTK+ is 2.2.4
> configure: error: Library requirements (gtk+-2.0 >= 2.4 gthread-2.0 >=
> 2.2 libart-2.0) not met; consider adjusting the PKG_CONFIG_PATH
> environment variable if your libraries are in a nonstandard prefix so
> pkg-config can find them.
It simply means that the version of gtk that came with your system is
too old and you need to upgrade it somehow. I have never used Suse
personally but some googling pointed me to http://www.usr-local-
bin.org/rpms/usr-local-bin.php which seems to hold more recent versions
of for example the gtk packages. You want at least the packages
Good luck upgrading!
More information about the kaffe