[kaffe] Bug report: kaffe fails on alpha

Dalibor Topic robilad at kaffe.org
Mon Aug 15 19:44:10 PDT 2005

Stefaan wrote:
> I've been trying to get kaffe to work on my alpha.  I got stuck after
> a while because I got errors saying:
>  Internal error: caught an unexpected exception.
>  Please check your CLASSPATH and your installation.
>  java/lang/ArrayIndexOutOfBoundsException
>  Aborted
> at different occasions (specifically, I tried to get gcjwebplugin to
> work with kaffe-1.1.5)

Hi Stefaan,

thanks for your bug report! The alpha arch port really needs a volunteer 
to revive it again. Kloeri is running a tinderclient with latest CVS 
head using the interpreter engine (rather than the jit), and for the 
past weeks it has been stuck on mostly failing on tests as well.

If you are interested in helping make kaffe work well on alpha, I'd 
suggest starting by configuring the kaffe build --with-intrp and going 
after the most obvious compiler warnings you encounter (and there should 
be plenty in current CVS head, as some additional warning flags have 
been turned on yesterday ;).

The goal would be to get the interpeter to pass all the tests. Then 
fixing the remaining issues with the jit should be much easier.

> I haven't tried the cvs.  If you think it's worth checking out, I'd be
> willing to give it a try.

I assume the results would be similar. Otoh, CVS head is pretty much 
where you want to start if you want to hack on fixing it, as it contains 
more than three months worth of fixes since 1.1.5 ;)

If you plan to work on CVS head, please hop by #kaffe on 
irc.freenode.org if you want some hands on help with configuring and 
building kaffe.

dalibor topic

More information about the kaffe mailing list